CRAN Package Check Results for Package IndexConstruction

Last updated on 2024-06-13 06:58:05 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.1-3 20.36 179.17 199.53 NOTE
r-devel-linux-x86_64-debian-gcc 0.1-3 0.59 1.70 2.29 ERROR
r-devel-linux-x86_64-fedora-clang 0.1-3 245.99 NOTE
r-devel-linux-x86_64-fedora-gcc 0.1-3 250.83 NOTE
r-devel-windows-x86_64 0.1-3 17.00 122.00 139.00 NOTE
r-patched-linux-x86_64 0.1-3 18.50 167.03 185.53 NOTE
r-release-linux-x86_64 0.1-3 22.06 171.64 193.70 NOTE
r-release-macos-arm64 0.1-3 57.00 NOTE
r-release-macos-x86_64 0.1-3 94.00 NOTE
r-release-windows-x86_64 0.1-3 18.00 122.00 140.00 NOTE
r-oldrel-macos-arm64 0.1-3 63.00 OK
r-oldrel-macos-x86_64 0.1-3 107.00 OK
r-oldrel-windows-x86_64 0.1-3 22.00 148.00 170.00 OK

Check Details

Version: 0.1-3
Check: Rd files
Result: NOTE checkRd: (-1) IndexComp.Rd:69: Lost braces in \itemize; \value handles \item{}{} directly checkRd: (-1) IndexComp.Rd:70: Lost braces in \itemize; \value handles \item{}{} directly checkRd: (-1) IndexComp.Rd:71: Lost braces in \itemize; \value handles \item{}{} directly checkRd: (-1) IndexComp.Rd:72: Lost braces in \itemize; \value handles \item{}{} directly checkRd: (-1) IndexComp.Rd:73: Lost braces in \itemize; \value handles \item{}{} directly checkRd: (-1) IndexComp.Rd:74: Lost braces in \itemize; \value handles \item{}{} directly checkRd: (-1) IndexComp.Rd:78: Lost braces in \itemize; \value handles \item{}{} directly checkRd: (-1) IndexComp.Rd:79: Lost braces in \itemize; \value handles \item{}{} directly checkRd: (-1) IndexComp.Rd:80: Lost braces in \itemize; \value handles \item{}{} directly checkRd: (-1) IndexComp.Rd:81: Lost braces in \itemize; \value handles \item{}{} directly Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64, r-patched-linux-x86_64, r-release-linux-x86_64, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-x86_64

Version: 0.1-3
Check: package dependencies
Result: ERROR Packages required but not available: 'lubridate', 'RcppBDT' See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’ manual. Flavor: r-devel-linux-x86_64-debian-gcc