CRAN Package Check Results for Package statnet

Last updated on 2019-09-22 05:46:24 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 2019.6 8.60 159.54 168.14 OK
r-devel-linux-x86_64-debian-gcc 2019.6 7.61 126.03 133.64 OK
r-devel-linux-x86_64-fedora-clang 2019.6 208.53 OK
r-devel-linux-x86_64-fedora-gcc 2019.6 200.85 OK
r-devel-windows-ix86+x86_64 2019.6 334.00 463.00 797.00 OK
r-patched-linux-x86_64 2019.6 8.89 154.11 163.00 OK
r-patched-solaris-x86 2019.6 298.10 OK
r-release-linux-x86_64 2019.6 8.55 156.46 165.01 OK
r-release-windows-ix86+x86_64 2019.6 131.00 384.00 515.00 OK
r-release-osx-x86_64 2019.6 OK
r-oldrel-windows-ix86+x86_64 2019.6 57.00 432.00 489.00 ERROR
r-oldrel-osx-x86_64 2019.6 ERROR

Check Details

Version: 2019.6
Check: examples
Result: ERROR
    Running examples in 'statnet-Ex.R' failed
    The error occurred in:
    
    
    R version 3.5.3 (2019-03-11) -- "Great Truth"
    Copyright (C) 2019 The R Foundation for Statistical Computing
    Platform: x86_64-w64-mingw32/x64 (64-bit)
    
    R is free software and comes with ABSOLUTELY NO WARRANTY.
    You are welcome to redistribute it under certain conditions.
    Type 'license()' or 'licence()' for distribution details.
    
     Natural language support but running in an English locale
    
    R is a collaborative project with many contributors.
    Type 'contributors()' for more information and
    'citation()' on how to cite R or R packages in publications.
    
    Type 'demo()' for some demos, 'help()' for on-line help, or
    'help.start()' for an HTML browser interface to help.
    Type 'q()' to quit R.
    
    > pkgname <- "statnet"
    > source(file.path(R.home("share"), "R", "examples-header.R"))
    > options(warn = 1)
    > options(pager = "console")
    > library('statnet')
    Loading required package: tergm
    Loading required package: ergm
    Loading required package: network
    network: Classes for Relational Data
    Version 1.15 created on 2019-04-01.
    copyright (c) 2005, Carter T. Butts, University of California-Irvine
     Mark S. Handcock, University of California -- Los Angeles
     David R. Hunter, Penn State University
     Martina Morris, University of Washington
     Skye Bender-deMoll, University of Washington
     For citation information, type citation("network").
     Type help("network-package") to get started.
    
    Error: package or namespace load failed for 'ergm' in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
     namespace 'Matrix' 1.2-15 is being loaded, but >= 1.2.17 is required
    Error: package 'ergm' could not be loaded
    Execution halted
Flavor: r-oldrel-windows-ix86+x86_64

Version: 2019.6
Check: package dependencies
Result: ERROR
    Packages required and available but unsuitable versions: ‘tergm’ ‘ergm’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-oldrel-osx-x86_64