CRAN Package Check Results for Package pspatreg

Last updated on 2022-08-11 05:54:37 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.4 53.31 480.92 534.23 OK
r-devel-linux-x86_64-debian-gcc 1.0.4 38.61 347.31 385.92 OK
r-devel-linux-x86_64-fedora-clang 1.0.4 622.20 NOTE
r-devel-linux-x86_64-fedora-gcc 1.0.4 625.54 OK
r-devel-windows-x86_64 1.0.4 86.00 449.00 535.00 OK
r-patched-linux-x86_64 1.0.4 44.55 451.31 495.86 OK
r-release-linux-x86_64 1.0.4 OK
r-release-macos-arm64 1.0.4 160.00 OK
r-release-macos-x86_64 1.0.4 200.00 OK
r-release-windows-x86_64 1.0.4 76.00 463.00 539.00 OK
r-oldrel-macos-arm64 1.0.4 7.00 ERROR
r-oldrel-macos-x86_64 1.0.4 190.00 OK
r-oldrel-windows-ix86+x86_64 1.0.4 105.00 404.00 509.00 ERROR

Check Details

Version: 1.0.4
Check: Rd cross-references
Result: NOTE
    Undeclared package ‘spsur’ in Rd xrefs
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 1.0.4
Check: package dependencies
Result: ERROR
    Package required and available but unsuitable version: ‘grDevices’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-oldrel-macos-arm64

Version: 1.0.4
Check: examples
Result: ERROR
    Running examples in 'pspatreg-Ex.R' failed
    The error most likely occurred in:
    
    > ### Name: impactsnopar
    > ### Title: Compute direct, indirect and total impacts functions for
    > ### continous non-parametric covariates in semiparametric spatial
    > ### regression models.
    > ### Aliases: impactsnopar
    >
    > ### ** Examples
    >
    > ################################################
    > # Examples using spatial data of Ames Houses.
    > ###############################################
    > # Getting and preparing the data
    > library(pspatreg)
    > library(spdep)
    Loading required package: sp
    Loading required package: spData
    To access larger datasets in this package, install the spDataLarge
    package with: `install.packages('spDataLarge',
    repos='https://nowosad.github.io/drat/', type='source')`
    Loading required package: sf
    Linking to GEOS 3.10.2, GDAL 3.4.1, PROJ 7.2.1; sf_use_s2() is TRUE
    > library(sf)
    > ames <- AmesHousing::make_ames() # Raw Ames Housing Data
    > ames_sf <- st_as_sf(ames, coords = c("Longitude", "Latitude"))
    > ames_sf$Longitude <- ames$Longitude
    > ames_sf$Latitude <- ames$Latitude
    > ames_sf$lnSale_Price <- log(ames_sf$Sale_Price)
    > ames_sf$lnLot_Area <- log(ames_sf$Lot_Area)
    > ames_sf$lnTotal_Bsmt_SF <- log(ames_sf$Total_Bsmt_SF+1)
    > ames_sf$lnGr_Liv_Area <- log(ames_sf$Gr_Liv_Area)
    > ########### Constructing the spatial weights matrix
    > ames_sf1 <- ames_sf[(duplicated(ames_sf$Longitude) == FALSE), ]
    > coord_sf1 <- cbind(ames_sf1$Longitude, ames_sf1$Latitude)
    > ID <- row.names(as(ames_sf1, "sf"))
    > col_tri_nb <- tri2nb(coord_sf1)
    > soi_nb <- graph2nb(soi.graph(col_tri_nb,
    + coord_sf1),
    + row.names = ID)
    Error in soi.graph(col_tri_nb, coord_sf1) : dbscan required
    Calls: graph2nb -> soi.graph
    Execution halted
Flavor: r-oldrel-windows-ix86+x86_64